华为配置基于VLAN限速示例

news/2024/4/24 16:57:17/文章来源:https://blog.csdn.net/weixin_59383576/article/details/136457512

华为配置基于VLAN限速示例

组网图形

图1 流量监管配置组网图
 

表1 Switch为上行流量提供的QoS保障

流量类型

CIR(kbps)

PIR(kbps)

DSCP优先级

语音

2000

10000

46

视频

4000

10000

30

数据

4000

10000

14

^^^

  • 流分类简介
  • 配置注意事项
  • 组网需求
  • 配置思路
  • 操作步骤
  • 配置文件

流分类简介

除了ACL之外,MQC配置中的流分类定义了大量的二三层匹配规则,如VLAN ID、802.1p优先级、DSCP优先级、源MAC、目的MAC等,设备可以通过配置不同的流分类规则将报文进行分类,并配置限速、统计或者镜像等流行为,以实现不同的策略。

本例就是在流分类中匹配不同的VLAN ID,并对符合规则的报文分别配置不同的限速带宽,以达到对不同的业务流量分配不同带宽的目的。

配置注意事项

如需了解交换机软件配套详细信息,请点击Info-Finder,在选择产品系列或产品型号后,在“硬件中心”进行查询。

S5731-L和S5731S-L属于远端模块,不支持Web管理、YANG和命令行,仅支持通过中心交换机对其下发配置,相关操作请参见《S300, S500, S2700, S5700, S6700 V200R022C00 配置指南-设备管理》中的“智能极简园区网络配置(小行星方案)”。

组网需求

Switch通过接口GE2/0/1与路由器互连,企业可经由Switch和路由器访问网络,如图1所示。

语音业务对应的VLAN ID为120,视频业务对应的VLAN ID为110,数据业务对应的VLAN ID为100。

在Switch上需要对不同业务的报文分别进行流量监管,以将流量限制在一个合理的范围之内,并保证各业务的带宽需求。

不同业务对于服务质量的需求不同,语音业务对服务质量要求最高,视频业务次之,数据业务要求最低,所以在Switch中还需要重标记不同业务报文的DSCP优先级,以便于路由器按照报文的不同优先级分别进行处理,保证各种业务的服务质量。

具体配置需求如表1所示。

配置思路

采用如下的思路配置MQC实现流量监管:

  1. 创建VLAN,并配置各接口,使企业能够通过Switch访问网络。
  2. 在Switch上配置基于VLAN ID进行流分类的匹配规则。
  3. 在Switch上配置流行为,对报文进行流量监管并且重标记报文的DSCP优先级。
  4. 在Switch上配置流量监管策略,绑定已配置的流行为和流分类,并应用到Switch与LSW连接的接口上。

操作步骤
  1. 创建VLAN并配置各接口

    # 在Switch上创建VLAN 100、110、120。<HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 110 120
    # 将接口GE1/0/1、GE2/0/1的接入类型分别配置为trunk,并分别将接口GE1/0/1和GE2/0/1加入VLAN 100、VLAN 110、VLAN 120。[Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 100 110 120
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 2/0/1
    [Switch-GigabitEthernet2/0/1] port link-type trunk
    [Switch-GigabitEthernet2/0/1] port trunk allow-pass vlan 100 110 120
    [Switch-GigabitEthernet2/0/1] quit

  2. 配置流分类
    # 在Switch上创建流分类c1~c3,对不同业务流按照其VLAN ID进行分类。[Switch] traffic classifier c1 operator and
    [Switch-classifier-c1] if-match vlan-id 120  //匹配VLAN ID为120的报文
    [Switch-classifier-c1] quit
    [Switch] traffic classifier c2 operator and
    [Switch-classifier-c2] if-match vlan-id 110  //匹配VLAN ID为110的报文
    [Switch-classifier-c2] quit
    [Switch] traffic classifier c3 operator and
    [Switch-classifier-c3] if-match vlan-id 100  //匹配VLAN ID为100的报文
    [Switch-classifier-c3] quit

  3. 配置流量监管行为
    
    # 在Switch上创建流行为b1~b3,对不同业务流进行流量监管以及重标记优先级,并配置流量统计功能。[Switch] traffic behavior b1
    [Switch-behavior-b1] car cir 2000 pir 10000 green pass  //对VLAN ID为120的报文限速为2000kbit/s
    [Switch-behavior-b1] remark dscp 46  //对VLAN ID为120的报文重标记其DSCP优先级为46
    [Switch-behavior-b1] statistic enable  //配置流量统计功能
    [Switch-behavior-b1] quit
    [Switch] traffic behavior b2
    [Switch-behavior-b2] car cir 4000 pir 10000 green pass
    [Switch-behavior-b2] remark dscp 30
    [Switch-behavior-b2] statistic enable
    [Switch-behavior-b2] quit
    [Switch] traffic behavior b3
    [Switch-behavior-b3] car cir 4000 pir 10000 green pass
    [Switch-behavior-b3] remark dscp 14
    [Switch-behavior-b3] statistic enable
    [Switch-behavior-b3] quit

  4. 配置流量监管策略并应用到接口上

    # 在Switch上创建流策略p1,将流分类和对应的流行为进行绑定并将流策略应用到接口GE1/0/1入方向上,对报文进行流量监管和重标记。[Switch] traffic policy p1
    [Switch-trafficpolicy-p1] classifier c1 behavior b1
    [Switch-trafficpolicy-p1] classifier c2 behavior b2
    [Switch-trafficpolicy-p1] classifier c3 behavior b3
    [Switch-trafficpolicy-p1] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-policy p1 inbound
    [Switch-GigabitEthernet1/0/1] quit

  5. 验证配置结果

    # 查看流分类的配置信息。[Switch] display traffic classifier user-definedUser Defined Classifier Information:Classifier: c2Precedence: 10Operator: ANDRule(s) : if-match vlan-id 110Classifier: c3Precedence: 15Operator: ANDRule(s) : if-match vlan-id 100Classifier: c1Precedence: 5Operator: ANDRule(s) : if-match vlan-id 120Total classifier number is 3 
    # 查看流策略的配置信息,以流策略p1为例。[Switch] display traffic policy user-defined p1User Defined Traffic Policy Information:Policy: p1Classifier: c2Operator: ANDBehavior: b2PermitCommitted Access Rate:CIR 4000 (Kbps), PIR 10000 (Kbps), CBS 500000 (byte), PBS 1250000 (byte)Color Mode: color BlindConform Action: passYellow  Action: passExceed  Action: discardRemark:                            Remark DSCP af33Statistic: enable Classifier: c3Operator: ANDBehavior: b3PermitCommitted Access Rate:CIR 4000 (Kbps), PIR 10000 (Kbps), CBS 500000 (byte), PBS 1250000 (byte)Color Mode: color BlindConform Action: passYellow  Action: passExceed  Action: discardRemark:Remark DSCP af13Statistic: enableClassifier: c1Operator: ANDBehavior: b1PermitCommitted Access Rate:CIR 2000 (Kbps), PIR 10000 (Kbps), CBS 250000 (byte), PBS 1250000 (byte)Color Mode: color BlindConform Action: passYellow  Action: passExceed  Action: discardRemark:Remark DSCP efStatistic: enable
    # 查看在接口上应用的流策略信息。以接口GE1/0/1上的语音业务报文为例,当报文速率大于10000kbit/s时会出现丢包,语音业务报文的速率被限制在10000kbit/s。[Switch] display traffic policy statistics interface gigabitethernet 1/0/1 inbound verbose classifier-base class c1Interface:  GigabitEthernet1/0/1Traffic policy inbound: p1Rule number: 3Current status: successStatistics interval: 300   
    ---------------------------------------------------------------------Board : 1
    ---------------------------------------------------------------------Matched          |      Packets:                        49,491|      Bytes:                               -|      Rate(pps):                           0|      Rate(bps):                           -
    ---------------------------------------------------------------------Passed         |      Packets:                        40,971|      Bytes:                               -|      Rate(pps):                           0|      Rate(bps):                           -
    ---------------------------------------------------------------------Dropped        |      Packets:                         8,520|      Bytes:                               -|      Rate(pps):                           0|      Rate(bps):                           -
    ---------------------------------------------------------------------Filter       |      Packets:                             0|      Bytes:                               -
    --------------------------------------------------------------------- Car          |      Packets:                         8,520|      Bytes:                               -
    ---------------------------------------------------------------------

配置文件
Switch的配置文件#
sysname Switch
#
vlan batch 100 110 120
#
traffic classifier c1 operator and precedence 5 if-match vlan-id 120
traffic classifier c2 operator and precedence 10if-match vlan-id 110
traffic classifier c3 operator and precedence 15if-match vlan-id 100
#
traffic behavior b1permitcar cir 2000 pir 10000 cbs 250000 pbs 1250000 mode color-blind green pass yellow pass red discardremark dscp efstatistic enable
traffic behavior b2permitcar cir 4000 pir 10000 cbs 500000 pbs 1250000 mode color-blind green pass yellow pass red discardremark dscp af33statistic enable
traffic behavior b3permitcar cir 4000 pir 10000 cbs 500000 pbs 1250000 mode color-blind green pass yellow pass red discardremark dscp af13statistic enable
#
traffic policy p1 match-order configclassifier c1 behavior b1classifier c2 behavior b2classifier c3 behavior b3
#
interface GigabitEthernet1/0/1port link-type trunkport trunk allow-pass vlan 100 110 120traffic-policy p1 inbound
#
interface GigabitEthernet2/0/1port link-type trunkport trunk allow-pass vlan 100 110 120
#
return

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.luyixian.cn/news_show_998223.aspx

如若内容造成侵权/违法违规/事实不符,请联系dt猫网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

Linux服务器安装jdk

背景: 安装JDK是我们java程序在服务器运行的必要条件,下面描述几个简单的命令就可再服务器上成功安装jdk 命令总览: yum update -y yum list | grep jdk yum -y install java-1.8.0-openjdk java -version 1.查看可安装版本 yum list | grep jdk 2.如果查不到可先进行 yum upd…

手写分布式配置中心(三)增加实时刷新功能(短轮询)

要实现配置自动实时刷新&#xff0c;需要改造之前的代码。代码在https://gitee.com/summer-cat001/config-center​​​​​​​ 服务端改造 服务端增加一个版本号version&#xff0c;新增配置的时候为1&#xff0c;每次更新配置就加1。 Overridepublic long insertConfigDO(…

ArcGIS学习(十)城市用地对比分析

ArcGIS学习(十)城市用地对比分析 1.城市用地变更分析 本任务给大家带来的内容是城市用地对比分析,包括两个关卡:城市用地变更分析 用地规划方案实施评价 城市用地变更分析和用地规划方案实施评价是我们进行用地分析时常见的两种场景。其中:城市用地变更分析主要是对不同…

访问修饰符、Object(方法,使用、equals)、查看equals底层、final--学习JavaEE的day15

day15 一、访问修饰符 含义&#xff1a; 修饰类、方法、属性&#xff0c;定义使用的范围 理解&#xff1a;给类、方法、属性定义访问权限的关键字 注意&#xff1a; ​ 1.修饰类只能使用public和默认的访问权限 ​ 2.修饰方法和属性可以使用所有的访问权限 访问修饰符本类本包…

H5小游戏,斗地主

H5小游戏源码、JS开发网页小游戏开源源码大合集。无需运行环境,解压后浏览器直接打开。有需要的,私信本人,发演示地址,可以后再订阅,发源码,含60+小游戏源码。如五子棋、象棋、植物大战僵尸、开心消消乐、扑鱼达人、飞机大战等等 <!DOCTYPE html> <html> <…

BERT学习【BERT的例子以及作用】

一、case 1.case1 多输入单输出。通过输入一个句子&#xff08;sequence&#xff09;&#xff0c;然后输出一个句子的分类&#xff08;这个句子是正向还是负向&#xff09;。将句子输入BERT&#xff0c;然后通过softmax输出分类。 2.case2 多输入多输出。输入一个句子&…

评测本地部署的语音识别模型

1 引言 最近&#xff0c;朋友给我发来了一段音频&#xff0c;想转录成文字&#xff0c;并使用大型润色文本。音频中的普通话带有一定的口音&#xff0c;并且讲解内容较为专业&#xff0c;所以一般的语音识别工具很难达到较高的识别率。 于是试用了两个大模型。Whisper 是目前…

ai脚本创作的软件有哪些?分享3款好用的工具!

随着人工智能技术的飞速发展&#xff0c;AI脚本创作软件已经成为内容创作者们的新宠。这些软件不仅能够帮助我们更高效地生成文章、视频脚本等&#xff0c;还能为我们提供独特的创意视角和无限的灵感。本文将带您深入了解几款备受瞩目的AI脚本创作软件&#xff0c;看看它们如何…

Truenas入门级教程

Truenas入门教程 前言&#xff1a;系统相关配置 采用I3 4160&#xff0c;采用了2块500G的硬盘&#xff0c;内存为8G&#xff0c;两个网卡只用了其中一个&#xff0c;系统安装的是core版本 硬件采用DELL3020MT机箱&#xff0c;自带3个SATA网口&#xff0c;后期网口不够&#…

C++:Stack和Queue的模拟实现

创作不易&#xff0c;感谢三连&#xff01; 一、容器适配器 适配器是一种设计模式(设计模式是一套被反复使用的、多数人知晓的、经过分类编目的、代码设计经验的总结)&#xff0c;该种模式是将一个类的接口转换成客户希望的另外一个接口。 就如同是电源适配器将不适用的交流电…

Java中的List

List集合的特有方法 方法介绍 方法名描述void add(int index,E element)在此集合中的指定位置插入指定的元素E remove(int index)删除指定索引处的元素&#xff0c;返回被删除的元素E set(int index,E element)修改指定索引处的元素&#xff0c;返回被修改的元素E get(int inde…

正则表达式-分组

1、oracle-正则表达式&#xff1a;将09/29/2008 用正则表达式转换成2008-09-29 select regexp_replace(09/29/2008, ^([0-9]{2})/([0-9]{2})/([0-9]{4})$, \3-\1-\2) replace from dual; 解析&#xff1a;regexp_replace-替换&#xff0c; 第一个参数&#xff1a;需要进行处…

《TCP/IP详解 卷一》第13章 TCP连接管理

目录 13.1 引言 13.2 TCP连接的建立与终止 13.2.1 TCP半关闭 13.2.2 同时打开与关闭 13.2.3 初始序列号 13.2.4 例子 13.2.5 连接建立超时 13.2.6 连接与转换器 13.3 TCP 选项 13.3.1 最大段大小选项 13.3.2 选择确认选项 13.3.3 窗口缩放选项 13.3.4 时间戳选项与…

DCFL: for Oriented Tiny Object Detection

文章目录 AbstractIntroductionContributionRelated Work定向目标检测微小目标检测多尺度学习标签分配上下文信息特征增强MethodOverview动态先验Coarse Prior MatchingFiner Dynamic Posterior MatchingAblation StudyAnalysis不平衡问题的调解可视化速度Conclusionhh 源代码 …

ArcGIS筛选工具:19段SQL示例代码,所有需求一网打尽

一、使用方法 筛选工具(Select_analysis)主要用于从输入要素类或输入要素图层中提取要素&#xff08;通常使用选择或结构化查询语言 (SQL) 表达式&#xff09;&#xff0c;并将其存储于输出要素类中。 以三调图斑为例&#xff0c;图斑中有一个【DLMC】字段&#xff0c;该字段…

1.3 数据库系统的结构

目录 1.3.1 数据库系统模式的概念 1.3.2 数据库系统的三级模式结构 1. 模式 2. 外模式 3.内模式&#xff08;也称存储模式&#xff09; 1.3.3 数据库的二级映像功能与数据独立性 1.外模式&#xff0f;模式映像 2.模式&#xff0f;内模式映像 1.3.4 总结 模式 内模式…

【python词云】根据文本生成简单词云图片(以豆瓣电影250为例,附源码)

效果图 代码 先在内置终端中安装模块 pip install wordcloudpip install jiebaimport wordcloud import jieba# 读入txt文本数据 f open("./douban250.txt", "r", encoding"utf-8") text f.read() f.close()# 切割分词 # jieba.lcut(text)就…

基于cnn卷积神经网络的车辆颜色检测识别-图像去雾-图像去雨(改进yolo目标检测-附代码)

– 引言&#xff1a; 开篇简述图像处理在智能交通监控、自动驾驶等领域的关键作用&#xff0c;并强调随着深度学习尤其是卷积神经网络&#xff08;CNN&#xff09;的发展&#xff0c;在复杂环境下的车辆颜色精确识别、图像恢复&#xff08;如去雾和去雨&#xff09;等难题得以…

Chromium内核浏览器编译记(四)Linux版本CEF编译

转载请注明出处&#xff1a;https://blog.csdn.net/kong_gu_you_lan/article/details/136508294 本文出自 容华谢后的博客 0.写在前面 本篇文章是用来记录编译Linux版本CEF的步骤和踩过的坑&#xff0c;以防止后续再用到的时候忘记&#xff0c;同时也希望能够帮助到遇到同样问…

【【C语言简单小题学习-1】】

实现九九乘法表 // 输出乘法口诀表 int main() {int i 0;int j 0;for (i 1; i < 9; i){for (j 1; j < i;j)printf("%d*%d%d ", i , j, i*j);printf("\n"); }return 0; }猜数字的游戏设计 #define _CRT_SECURE_NO_WARNINGS 1 #include<stdi…