记录我在百度地图开发和ArcGIS for Android开发时出现的一些错误及解决方案(后续更新)...

2019/7/22 15:58:10 人评论 次浏览 分类:android

原文链接:http://www.cnblogs.com/David-Young/p/3702415.html

[1]The import com.baidu.mapapi.map.Geometry conflicts with a type defined in the same file

解决:百度api包下的Geometry和某个类名相冲突,将类名换成另外的名字,不要和百度相关类里面的类名相同

[2]java.lang.ClassCastException:

解决:类型转换错误。查看Test_Geometry项目的Mainfest.xml清单文件,在<applicaiton>标签里面少了对Myapplication类(地图相关设置)的权限声明; 另外就有可能是中间代码有错误,仔细检查关键代码位置,是否有写错。

[3]org.eclipse.jdi.TimeoutException:Timeout occurred while waittingfor packet100524.occurred

creatingstep request

解决:连接超时,在G:\workspace\.metadata\.plugins\org.eclipse.core.runtime\.settings目录下将时间改大一些

[4]Error parsing XML: junk after document element

解决:布局文件里面主根有多个节点,一个合法XML文件只有一个主根节点,检查<.../>

[5]java.lang.reflect.InvocationTargetException

解决:之前找了一个Demo使用的3.0版本的百度定位包,后面换使用百度定位SDK4.x版本时,一直出错出现这个错误,后面查了帮助文档,SDK4.x版本要在Manifest.xml里面的Application标签里面设置Accesskey,设置有误会引起定位和地理围栏服务不能正常使用。

[6] Unable to resolve target 'android-7'

解决:这是低版本的代码导入eclipse时常遇到的错误,在源代码中project.properties的Project target设置与当前eclipse环境设置不一致。把Project target.target=android-7 改为你当前支持的AVD版本即可。一般 android-8对应的android sdk 是2.2, android-10对应的是2.3,注意修改文件的时候不要随意删除空格和占位符 查看开发环境sdk对应的API序号(在android sdk manager中可以查看)

[7]Installation error: INSTALL_FAILED_INSUFFICIENT_STORAGE

解决:安装失败,手机内存不够,卸载一些程序;把之前安装的同名程序卸载掉

[8]新建ArcGIS for Android的sample项目,不显示地图或出错

解决:真正的原因是:Revision17的Android SDK和Eclipse ADT插件包括重大改变的依赖管理的Android项目,将会打破现有的ArcGIS Android SDK的项目。这是他们ArcGis在设计ArcGIS for Android API时候的问题。 1、在你的工程上右击,选择Build Path>Configure Build Path…如图所示,选中所有ArcGIS_For_Android选项,然后OK。2、再在工程上右击,选择 Android Tools,点击Fix Project Properties。

[9]新建ArcGIS Project for Android项目时失败,出现Problem Opening Wizard 解决:

无法打开向导。新建一个Android工程项目,然后可以在新建的工程中右键-->Properties-->添加jar包的形式

手动添加arcgis的五个包,这样就是一个arcgis api项目了

[9]Invaild project desciption

解决:Android导入一个工程时提示 Invalid project description字样,导入的项目位置与另外一个项目重叠 不要把程序包放在eclipse默认的工作空间中,放到其他文件夹再导入即可

[10]Unable to execute dex: java.nio.BufferOverflowException. Check the Eclipse log for stack trace.

解决:由于错误的添加了不必要的core library或重复添加了同一个library jar包产生冲突造成的,右键项目,选择Java Build Path—Librarise,移除Android Dependencies,注意每次启动eclipse都要执行此操作

[11]Eclipse中解决“Save could not be completed”问题

解决:在Eclipse --> window --> Preferences --> General --> Content Types --> Text --> 单击 Java Properties File,在底部出现 'Default edcodng:',改成UTF-8(注:原ISO-8859-1),然后update

[12]eclipse 写 android 自动添加事件,报错 The method setOnClickListener(View.OnClickListener) in the

type View is not applicable for the arguments (new OnClickListener(){})

解决:差了个包没添加import android.view.View.OnClickListener;

[13]使用手机调试程序的时候java.io.IOException: Unable to open sync connection!

解决:关掉USB调试,重新开始

[14]修改Android项目的SDK版本

解决:1、右键单击项目---properties----Resource-----Android在Project Bulid Target对话框中选择你需要的Android版本。 2、Resource---Libraries对话框右边的 Addlibraries---Android Classpath Containe

[15]java.io.IOException: 远程主机强迫关闭了一个现有的连接。

解决:重启eclipse和adb即可

[16]java.lang.ClassCastException: android.widget.Button cannot be cast to com.esri.android.map.MapView

解决:重启eclipse

[17]Invalid file name: must contain only [a-z0-9_.]

解决:错误的文件名字:必须包含且仅包含字母a-z、数字0-9和符合"_"与"."。[a-z0-9_.] 是个正则表达式。  如:Effect for alarm.mp3中的大写字母E不符合命名规范

[18]添加demo时,出现Application does not specify a android.test.InstrumentationTestRunner instrumentation or does not declare uses-library android.test.runner的错误提示

解决:在Run as里面删除Adroid JUnit Test,然后在Android application里面新建一个

[19]Conversion to Dalvik format failed: Unable to execute dex: java.nio.BufferOverflowException. Check the Eclipse log for stack trace.

解决:见bug[10]

[20]在res目录下新建raw文件夹,放入文件时出错,不能成功在R下生成id

解决:放入的文件名不能为中文

[21]无法在Android SDK Manager里面通过https://dl-ssl.google.com/android/eclipse/在线安装更新ADT

解决:在线安装比较慢,直接下载离线安装包,可以通过eclipse里面的在线安装地址Install New Software获取ADT的最新版本,然后通过这个链接http://dl.google.com/android/ADT-xx.x.x.zip来进行下载了(xx.x.x是最新版本号)

转载于:https://www.cnblogs.com/David-Young/p/3702415.html

相关资讯

    暂无相关的资讯...

共有访客发表了评论 网友评论

验证码: 看不清楚?
    -->